Welcome! » Log In » Create A New Profile

Sun StoreEdge L700 with MTX

Posted by therm 
Sun StoreEdge L700 with MTX
March 28, 2011 04:28AM
Hello @all,

yesterday we got a Sun Storedge L700 with 3 Drives LTO4 and 678 slots.
I can use mtx for changing the tapes from every slot to every slot, no
problem. My problem is that it moans if I want to load these tapes into the drives.
But I see people using this autochanger in the internet, what did I wrong?

Here is what I am doing:

root@amanda:~# lsscsi -g
[0] cd/dvd hp DVD RW AD-7586H KP03 /dev/sr0 /dev/sg0
[2] storage HP HSV200 6220 - /dev/sg3
[2] storage HP HSV200 6220 - /dev/sg4
[2] mediumx STK L700 0318 /dev/sch0 /dev/sg7 <-----
[2] tape IBM ULTRIUM-TD4 A232 /dev/st0 /dev/sg8
[2] tape IBM ULTRIUM-TD4 A232 /dev/st1 /dev/sg9
[2] tape IBM ULTRIUM-TD4 A232 /dev/st2 /dev/sg10
[3] storage HP P410i 3.66 - /dev/sg1
[3] disk HP LOGICAL VOLUME 3.66 /dev/sda /dev/sg2
[4] storage HP HSV200 6220 - /dev/sg5
[4] storage HP HSV200 6220 - /dev/sg6

root@amanda:~# mtx -f /dev/sg7 status
Storage Changer /dev/sg7:3 Drives, 698 Slots ( 20 Import/Export )
Data Transfer Element 0:Empty
Data Transfer Element 1:Empty
Data Transfer Element 2:Empty
Storage Element 1:Full :VolumeTag=DAY$02
Storage Element 2:Empty
Storage Element 3:Empty
Storage Element 4:Full :VolumeTag=DAY$07
Storage Element 5:Full :VolumeTag=DAY$02
Storage Element 6:Full :VolumeTag=DAY$07
Storage Element 7:Full :VolumeTag=DAY$00
Storage Element 8:Empty
Storage Element 9:Empty
Storage Element 10:Full :VolumeTag=DAY$07
Storage Element 11:Empty
Storage Element 12:Empty
Storage Element 13:Empty
Storage Element 14:Empty
Storage Element 15:Empty
Storage Element 16:Empty
Storage Element 17:Empty
Storage Element 18:Empty
Storage Element 19:Empty
Storage Element 20:Empty
...
Storage Element 679 IMPORT/EXPORT:Empty
Storage Element 680 IMPORT/EXPORT:Empty
Storage Element 681 IMPORT/EXPORT:Empty
Storage Element 682 IMPORT/EXPORT:Empty
Storage Element 683 IMPORT/EXPORT:Empty
Storage Element 684 IMPORT/EXPORT:Empty
Storage Element 685 IMPORT/EXPORT:Empty
Storage Element 686 IMPORT/EXPORT:Empty
Storage Element 687 IMPORT/EXPORT:Empty
Storage Element 688 IMPORT/EXPORT:Empty
Storage Element 689 IMPORT/EXPORT:Empty
Storage Element 690 IMPORT/EXPORT:Empty
Storage Element 691 IMPORT/EXPORT:Empty
Storage Element 692 IMPORT/EXPORT:Empty
Storage Element 693 IMPORT/EXPORT:Empty
Storage Element 694 IMPORT/EXPORT:Empty
Storage Element 695 IMPORT/EXPORT:Empty
Storage Element 696 IMPORT/EXPORT:Empty
Storage Element 697 IMPORT/EXPORT:Empty
Storage Element 698 IMPORT/EXPORT:Empty

root@amanda:~# mtx -f /dev/sg7 transfer 4 3 (runs perfectly)

root@amanda:~# mtx -f /dev/sg7 load 3
or root@amanda:~# mtx -f /dev/sg7 load 3 0
instead will fail with the following error message:
Loading media from Storage Element 3 into drive 0...mtx: Request Sense:
Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Illegal Request
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 30
mtx: Request Sense: Additional Sense Qualifier = 00
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
MOVE MEDIUM from Element Address 1002 to 500 Failed

I phoned the seller of this and they said that they checked the library
with their tool and everything was ok.
Do I make something wrong or do have any recommendation?

--
Best Regards,
Dennis Benndorf
Sun StoreEdge L700 with MTX
March 28, 2011 07:26AM
No idea why but the changer seems to detected wether it is a LTO4 or not.
The error "mtx: Request Sense: Additional Sense Code = 30 " does mean
"INCOMPATIBLE MEDIUM INSTALLED" and because of this it declines to load
the media. After changing all LTO3 tapes to LTO4 loading does complete.

See also: [sourceforge.net]
Sorry, only registered users may post in this forum.

Click here to login