Welcome! » Log In » Create A New Profile

tape device order in amanda.conf

Posted by Luc Lalonde 
Luc Lalonde
tape device order in amanda.conf
January 13, 2018 03:59PM
Hello Folks,

I’m getting a strange result when I do an ‘amcheck’:

slot 3: Tape device /dev/nst1 is not ready or is empty
slot 4:Slot 4, label '000279L7', mismatch barcode between changer '000280L7' and tapelist file '000279L7'
ERROR: Slot 4, label '000279L7', mismatch barcode between changer '000280L7' and tapelist file ‘000279L7'

Here’s what I have in my config file:

define changer spectra-robot {
tapedev "chg-robot:/dev/changer"
property "tape-device” "0=tape:/dev/nst0"
property append "tape-device” "1=tape:/dev/nst1"
device-property "BLOCK_SIZE" "512k"
property "use-slots" "1-47”
}

To get rid of the problem, I reverse the tape device order:

define changer spectra-robot {
tapedev "chg-robot:/dev/changer"
property "tape-device" "1=tape:/dev/nst0"
property append "tape-device" "0=tape:/dev/nst1"
device-property "BLOCK_SIZE" "512k"
property "use-slots" "1-47”
}

Here’s the pertinent lines of the ‘amcheck’ after having made this change:

slot 3: volume '000279L7'
Will write to volume '000279L7' in slot 3.

What going on? If it can help, here’s the output of ‘lsscsi -g’ (I removed the non-tape + changer lines):

[1:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st0 /dev/sg10
[2:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st1 /dev/sg13
[2:0:4:1] mediumx SPECTRA PYTHON 2000 /dev/sch0 /dev/sg14

And here’s an output of the first few lines of the command ‘mtx status’:

Storage Changer /dev/changer:2 Drives, 48 Slots ( 1 Import/Export )
Data Transfer Element 0:Empty
Data Transfer Element 1:Full (Storage Element 3 Loaded):VolumeTag = 000279L7
Storage Element 1:Full :VolumeTag=000277L7
Storage Element 2:Full :VolumeTag=000278L7
Storage Element 3:Empty
Storage Element 4:Full :VolumeTag=000280L7

I’m using a 50 slot SpectraLogic T50e library with two LTO7 IBM drives.

Thanks!
This message was imported via the External PhorumMail Module
Jean-Louis Martineau
Re: tape device order in amanda.conf
January 15, 2018 05:59AM
Luc,

The assignment of 'Data Transfer Element 0' to '/dev/nst1' and 'Data
Transfer Element 1' to '/dev/nst0' is done by the kernel.

You can use the 'amtape CONF verify' command to check if you correctly
configured amanda.

Jean-Louis


On 13/01/18 06:40 PM, Luc Lalonde wrote:
> Hello Folks,
>
> I’m getting a strange result when I do an ‘amcheck’:
>
> slot 3: Tape device /dev/nst1 is not ready or is empty
> slot 4:Slot 4, label '000279L7', mismatch barcode between changer '000280L7' and tapelist file '000279L7'
> ERROR: Slot 4, label '000279L7', mismatch barcode between changer '000280L7' and tapelist file ‘000279L7'
>
> Here’s what I have in my config file:
>
> define changer spectra-robot {
> tapedev "chg-robot:/dev/changer"
> property "tape-device” "0=tape:/dev/nst0"
> property append "tape-device” "1=tape:/dev/nst1"
> device-property "BLOCK_SIZE" "512k"
> property "use-slots" "1-47”
> }
>
> To get rid of the problem, I reverse the tape device order:
>
> define changer spectra-robot {
> tapedev "chg-robot:/dev/changer"
> property "tape-device" "1=tape:/dev/nst0"
> property append "tape-device" "0=tape:/dev/nst1"
> device-property "BLOCK_SIZE" "512k"
> property "use-slots" "1-47”
> }
>
> Here’s the pertinent lines of the ‘amcheck’ after having made this change:
>
> slot 3: volume '000279L7'
> Will write to volume '000279L7' in slot 3.
>
> What going on? If it can help, here’s the output of ‘lsscsi -g’ (I removed the non-tape + changer lines):
>
> [1:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st0 /dev/sg10
> [2:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st1 /dev/sg13
> [2:0:4:1] mediumx SPECTRA PYTHON 2000 /dev/sch0 /dev/sg14
>
> And here’s an output of the first few lines of the command ‘mtx status’:
> Data Transfer Element 0
>
> Storage Changer /dev/changer:2 Drives, 48 Slots ( 1 Import/Export )
> Data Transfer Element 0:Empty
> Data Transfer Element 1:Full (Storage Element 3 Loaded):VolumeTag = 000279L7
> Storage Element 1:Full :VolumeTag=000277L7
> Storage Element 2:Full :VolumeTag=000278L7
> Storage Element 3:Empty
> Storage Element 4:Full :VolumeTag=000280L7
>
> I’m using a 50 slot SpectraLogic T50e library with two LTO7 IBM drives.
>
> Thanks!
>
>
>
>
>
This message is the property of CARBONITE, INC. and may contain confidential or privileged information.
If this message has been delivered to you by mistake, then do not copy or deliver this message to anyone. Instead, destroy it and notify me by reply e-mail
This message was imported via the External PhorumMail Module
Luc Lalonde
Re: tape device order in amanda.conf
January 15, 2018 07:59AM
Ok, thanks for the tip:

[root@ulysses ~]# su amandabackup -c '/usr/sbin/amtape Mensuel-LTO7 verify'
GOOD : Drive 0 is device tape:/dev/nst1
GOOD : Drive 1 is device tape:/dev/nst0
property "TAPE-DEVICE" "0=tape:/dev/nst1" "1=tape:/dev/nst0"

Best regards, Luc.


On 2018-01-15 08:10 AM, Jean-Louis Martineau wrote:
> Luc,
>
> The assignment of 'Data Transfer Element 0' to '/dev/nst1' and 'Data
> Transfer Element 1' to '/dev/nst0' is done by the kernel.
>
> You can use the 'amtape CONF verify' command to check if you correctly
> configured amanda.
>
> Jean-Louis
>
>
> On 13/01/18 06:40 PM, Luc Lalonde wrote:
> > Hello Folks,
> >
> > I’m getting a strange result when I do an ‘amcheck’:
> >
> > slot 3: Tape device /dev/nst1 is not ready or is empty
> > slot 4:Slot 4, label '000279L7', mismatch barcode between changer
> '000280L7' and tapelist file '000279L7'
> > ERROR: Slot 4, label '000279L7', mismatch barcode between changer
> '000280L7' and tapelist file ‘000279L7'
> >
> > Here’s what I have in my config file:
> >
> > define changer spectra-robot {
> > tapedev "chg-robot:/dev/changer"
> > property "tape-device” "0=tape:/dev/nst0"
> > property append "tape-device” "1=tape:/dev/nst1"
> > device-property "BLOCK_SIZE" "512k"
> > property "use-slots" "1-47”
> > }
> >
> > To get rid of the problem, I reverse the tape device order:
> >
> > define changer spectra-robot {
> > tapedev "chg-robot:/dev/changer"
> > property "tape-device" "1=tape:/dev/nst0"
> > property append "tape-device" "0=tape:/dev/nst1"
> > device-property "BLOCK_SIZE" "512k"
> > property "use-slots" "1-47”
> > }
> >
> > Here’s the pertinent lines of the ‘amcheck’ after having made this
> change:
> >
> > slot 3: volume '000279L7'
> > Will write to volume '000279L7' in slot 3.
> >
> > What going on? If it can help, here’s the output of ‘lsscsi -g’ (I
> removed the non-tape + changer lines):
> >
> > [1:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st0 /dev/sg10
> > [2:0:4:0] tape IBM ULTRIUM-HH7 G9Q1 /dev/st1 /dev/sg13
> > [2:0:4:1] mediumx SPECTRA PYTHON 2000 /dev/sch0 /dev/sg14
> >
> > And here’s an output of the first few lines of the command ‘mtx status’:
> > Data Transfer Element 0
> >
> > Storage Changer /dev/changer:2 Drives, 48 Slots ( 1 Import/Export )
> > Data Transfer Element 0:Empty
> > Data Transfer Element 1:Full (Storage Element 3 Loaded):VolumeTag =
> 000279L7
> > Storage Element 1:Full :VolumeTag=000277L7
> > Storage Element 2:Full :VolumeTag=000278L7
> > Storage Element 3:Empty
> > Storage Element 4:Full :VolumeTag=000280L7
> >
> > I’m using a 50 slot SpectraLogic T50e library with two LTO7 IBM drives.
> >
> > Thanks!
> >
> >
> >
> >
> >
>
>
> *Disclaimer*
>
> This message is the property of *CARBONITE, INC.*
> http://www.carbonite.com and may contain confidential or privileged
> information.
>
> If this message has been delivered to you by mistake, then do not copy
> or deliver this message to anyone. Instead, destroy it and notify me
> by reply e-mail.
>

--
Luc Lalonde, analyste
-----------------------------
Département de génie informatique:
École polytechnique de MTL
(514) 340-4711 x5049
Luc.Lalonde@polymtl.ca
-----------------------------
This message was imported via the External PhorumMail Module
Sorry, only registered users may post in this forum.

Click here to login