Welcome! » Log In » Create A New Profile

Restore fails with host mars has mismatching netbios n

Posted by Anonymous 
Restore fails with host mars has mismatching netbios n
August 17, 2016 10:42PM
Hi Backuppc-Users,

I am new to this list so please bare with me in case I am doing
something odd.

I am have been using backuppc on a debian 8.5 vm server since quite some
time now and have made backups and restores successfully to a remote
system called "mars" with a given fixed ip-address.
I am still running version 3.3.0 on a debian 8.5 Linux System.

Today, I wanted to restore a single file and got the message

2016-08-15 11:43:29 restore failed (host mars has mismatching netbios
name )

I restarted both the debian vm system as well as the windows 7 host but
the result is the same. I saw a potential problem occuring in case there
is a Wifi on the same system life, but it isn't.

I checked

# ifconfig
eth0 Link encap:Ethernet Hardware Adresse 00:0c:29:4f:73:82
inet Adresse:192.168.1.38 Bcast:192.168.1.255
Maske:255.255.255.0
inet6-Adresse: fe80::20c:29ff:fe4f:7382/64
Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:24940 errors:0 dropped:1 overruns:0 frame:0
TX packets:12009 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:4221114 (4.0 MiB) TX bytes:8086940 (7.7 MiB)

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:65536 Metrik:1
RX packets:9000 errors:0 dropped:0 overruns:0 frame:0
TX packets:9000 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:4706177 (4.4 MiB) TX bytes:4706177 (4.4 MiB)

and .....

# perl -e 'print(gethostbyname("mars") ? "okn" : "not foundn");'
# ok

but this does not really indicate the problem to me.

It is important to say that the backup works, the restore doesn't. The
last successfull restore was on 14th of june. The only thing I am aware
having changed is the
upgrade vom debian 8.3 to 8.5 but I wouldn't really know how that could
harm it.

Any hint/suggestion is welcome.

Best regards

Andreas from germany

------------------------------------------------------------------------------
_______________________________________________
BackupPC-users mailing list
BackupPC-users < at > lists.sourceforge.net
List: https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki: http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/
Restore fails with host mars has mismatching netbios n
August 17, 2016 11:54PM
On 2016-08-18 00:39, ab < at > berner-telecom.de wrote:
[quote]Hi Backuppc-Users,

I am new to this list so please bare with me in case I am doing
something odd.

I am have been using backuppc on a debian 8.5 vm server since quite
some
time now and have made backups and restores successfully to a remote
system called "mars" with a given fixed ip-address.
I am still running version 3.3.0 on a debian 8.5 Linux System.

Today, I wanted to restore a single file and got the message

2016-08-15 11:43:29 restore failed (host mars has mismatching netbios
name )
[/quote]
This indicates:
- You are using smb
- Nmblookup is returning something that doesn't jive. Maybe multiple IP
addresses, maybe a different workgroup or system name than expected.
That's the place to start.

[quote]I restarted both the debian vm system as well as the windows 7 host but
the result is the same. I saw a potential problem occuring in case
there
is a Wifi on the same system life, but it isn't.

I checked

# ifconfig
eth0 Link encap:Ethernet Hardware Adresse 00:0c:29:4f:73:82
inet Adresse:192.168.1.38 Bcast:192.168.1.255
Maske:255.255.255.0
inet6-Adresse: fe80::20c:29ff:fe4f:7382/64
Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:24940 errors:0 dropped:1 overruns:0 frame:0
TX packets:12009 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:4221114 (4.0 MiB) TX bytes:8086940 (7.7 MiB)

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:65536 Metrik:1
RX packets:9000 errors:0 dropped:0 overruns:0 frame:0
TX packets:9000 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:4706177 (4.4 MiB) TX bytes:4706177 (4.4 MiB)

and .....

# perl -e 'print(gethostbyname("mars") ? "okn" : "not foundn");'
# ok

but this does not really indicate the problem to me.

It is important to say that the backup works, the restore doesn't. The
last successfull restore was on 14th of june. The only thing I am aware
having changed is the
upgrade vom debian 8.3 to 8.5 but I wouldn't really know how that could
harm it.

Any hint/suggestion is welcome.

Best regards

Andreas from germany
[/quote]
Use nmblookup from the backuppc side and ipconfig /all from the guest
side.

------------------------------------------------------------------------------
_______________________________________________
BackupPC-users mailing list
BackupPC-users < at > lists.sourceforge.net
List: https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki: http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/
Restore fails with host mars has mismatching netbios n
August 18, 2016 08:55AM
Could be related to a recent Windows update.  We had to set the following registry key.

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetservicesNetBTParameters]
"AllowNBToInternet"=dword:00000001

Reference : [url=https://support.microsoft.com/en-us/kb/3161949]https://support.microsoft.com/en-us/kb/3161949[/url]
Sorry, only registered users may post in this forum.

Click here to login