Welcome! » Log In » Create A New Profile

backups failing

Posted by Richard Hector 
Richard Hector
backups failing
February 05, 2018 03:59AM
Hi all,

I have a problem with an (inherited) rdiff-backup setup - actually used
from backupninja.

When I try to run a backup, I get:

OSError: [Errno 2] No such file or directory:
<redacted>/foo.2018-01-30T08:55:35Z.dir

I get the same thing if I run with --check-destination-dir.

I'm not clear why the file is missing, but probably due to a backup that
stopped part way through for some reason.

I'm also not clear why the file needs to be there in the first place -
should there be one for every directory for every backup (that hasn't
been deleted yet)?

I've tried just copying the previous one to the name that's missing
(they're all size 0), and am re-running --check-destination-dir. I
suspect it won't be the only file affected though.

It's a bit fiddly, because I don't have shell access to the destination
machine - it's rsync.net, and I can only run certain provided commands.
I guess that also means I couldn't patch the remote copy of
rdiff-backup, if I found a way to fix it.

Any tips?

Cheers,
Richard

_______________________________________________
rdiff-backup-users mailing list at rdiff-backup-users@nongnu.org
https://lists.nongnu.org/mailman/listinfo/rdiff-backup-users
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki
This message was imported via the External PhorumMail Module
Sorry, only registered users may post in this forum.

Click here to login