Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /home/pbuc/public_html/forum/mods/ext_phorummail/ezc/Base/src/ezc_bootstrap.php on line 36

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; KeyCAPTCHA_CLASS has a deprecated constructor in /home/pbuc/public_html/forum/mods/keycaptcha/keycaptcha.php on line 108
rsnapshot marked as broken with perl 5.18 on FreeBSD
Welcome! » Log In » Create A New Profile

rsnapshot marked as broken with perl 5.18 on FreeBSD

Posted by Anonymous 
rsnapshot marked as broken with perl 5.18 on FreeBSD
December 05, 2014 05:20PM
Hello,

I centralize my backup on a FreeBSD 10.0 machine, and I'm very happy
with it !

But few days ago they have updated the perl version, and now the package
is marked as broken on perl 5.18 and newer
http://www.freshports.org/sysutils/rsnapshot/
It cannot be build anymore

Can someone have a look ? I put the maintainer in copy

Cheers,Aurelien

------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsnapshot marked as broken with perl 5.18 on FreeBSD
December 05, 2014 08:01PM
Dear Aurelien,
--------------------------------------------
From: Aurelien Martin <01aurelien < at > gmail.com>
Sent: Fri, 05 Dec 2014 18:17:00 +0100
To: rsnapshot-discuss < at > lists.sourceforge.net Cc: r.vdooren < at > snow.nl
Subject: [rsnapshot-discuss] rsnapshot marked as broken with perl 5.18 on FreeBSD
[quote]
Hello,

I centralize my backup on a FreeBSD 10.0 machine, and I'm very happy
with it !

But few days ago they have updated the perl version, and now the package
is marked as broken on perl 5.18 and newer
http://www.freshports.org/sysutils/rsnapshot/
It cannot be build anymore
[/quote]
Well the freshports page says that it was test with perl 5.8.1 as the latest
and the github project page for rsnapshot says tested with perl 1.16.3:
https://github.com/DrHyde/rsnapshot

The make file says its broken, too:
https://svnweb.freebsd.org/ports/head/sysutils/rsnapshot/Makefile?revision=371526&view=co

.if ${PERL_VER} >= 5.18
BROKEN= Does not build with Perl 5.18 or above
.endif

Maybe you can be dangerous and try building from github source in a jail. ;)

It would be good to know if the rsnapshot project will test with perl 5.18,
though.

[quote]
Can someone have a look ? I put the maintainer in copy

Cheers,Aurelien

[/quote]
Best,
J.b.
--
inum: 883510009027723
sip: jungleboogie < at > sip2sip.info
xmpp: jungle-boogie < at > jit.si

------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsnapshot marked as broken with perl 5.18 on FreeBSD
December 08, 2014 09:53AM
On Fri, Dec 05, 2014 at 06:17:00PM +0100, Aurelien Martin wrote:
[quote]But few days ago they have updated the perl version, and now the package
is marked as broken on perl 5.18 and newer
http://www.freshports.org/sysutils/rsnapshot/
It cannot be build anymore
[/quote]
It's just a change in the documentation syntax:

# make
pod2man -c '' -n 'rsnapshot' -r '' rsnapshot > rsnapshot.1
rsnapshot around line 6723: You forgot a '=back' before '=head1'
POD document had syntax errors at /usr/local/bin/pod2man line 71.
*** Error code 255

Just create this dir+file, pimp the Makefile and run a clean make:

# cat /usr/ports/sysutils/rsnapshot/files/patch-rsnapshot-program.pl
--- rsnapshot-program.pl~ 2014-12-08 10:16:41.000000000 +0100
+++ rsnapshot-program.pl 2014-12-08 10:25:27.000000000 +0100
< at > < at > -6716,6 +6716,8 < at > < at >

=back

+=back
+
=head1 USAGE

B<rsnapshot> can be used by any user, but for system-wide backups

Already fixed in upstream:
https://github.com/DrHyde/rsnapshot/issues/8

--
Oliver PETER oliver < at > gfuzz.de 0x456D688F

------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=164703151&iu=/4140/ostg.clktrk
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
Sorry, only registered users may post in this forum.

Click here to login