Welcome! » Log In » Create A New Profile

rsync error 2

Posted by Anonymous 
rsync error 2
January 06, 2016 04:39AM
Hello,

I recently upgraded Wheezy backup server to Jessie and since then I'm having
problem with rsnapshot. I'm getting:

/usr/bin/rsnapshot -V sync: ERROR: /usr/bin/rsync returned 2 while
processing backup < at > host

Running rsync commands from
rsnapshot -t daily
manually works, it's just that it doesn't work when called from
rsnapshot.

What could be the problem?

Thanks!

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 07:21AM
Hi,

On 16-01-06 13:37, Прокси wrote:
[quote]Hello,

I recently upgraded Wheezy backup server to Jessie and since then I'm having
problem with rsnapshot. I'm getting:

/usr/bin/rsnapshot -V sync: ERROR: /usr/bin/rsync returned 2 while
processing backup < at > host

Running rsync commands from
rsnapshot -t daily
manually works, it's just that it doesn't work when called from
rsnapshot.

What could be the problem?
[/quote]
Have you customized ssh_args by any chance?

Cheers,
Miklós
--

------------------------------------------------------------------------------

_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 08:14AM
On 2016-Jan-06 16:00, PASZTOR Miklos wrote:
[quote]Have you customized ssh_args by any chance?
[/quote]
No, that line is commented. I do have something like this:

backup backup < at > ip:/ host rsync_long_args=--rsync-path='/usr/local/bin/rsync_wrapper.sh' --exclude-from=/etc/rsnapshot.d/host --delete-excluded

Some of those arguments could be in ssh_args if I'm not mistaken.

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 08:28AM
On 2016-Jan-06 17:14, Benedikt Heine wrote:
[quote]Could you please provide details of the complete error message from rsync
(triggering it via -v). rsync doesn't return just an exit code. And closes
without error description.
[/quote]
Sure.

/usr/bin/rsync -a --rsync-path='/usr/local/bin/rsync_wrapper.sh'
--exclude-from=/etc/rsnapshot.d/host --delete-excluded
--rsh=/usr/bin/ssh backup < at > ip:/
/mnt/backup/.sync/host
protocol version mismatch -- is your shell clean?
(see the rsync man page for an explanation)
rsync error: protocol incompatibility (code 2) at compat.c(176) [Receiver=3.1.1]
----------------------------------------------------------------------------
rsnapshot encountered an error! The program was invoked with these options:
/usr/bin/rsnapshot -v sync
----------------------------------------------------------------------------
ERROR: /usr/bin/rsync returned 2 while processing backup < at > ip:/

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 08:34AM
On 16-01-06 17:12, Прокси wrote:
[quote]On 2016-Jan-06 16:00, PASZTOR Miklos wrote:
[quote]Have you customized ssh_args by any chance?
[/quote]
No, that line is commented. I do have something like this:

backup backup < at > ip:/ host rsync_long_args=--rsync-path='/usr/local/bin/rsync_wrapper.sh' --exclude-from=/etc/rsnapshot.d/host --delete-excluded

Some of those arguments could be in ssh_args if I'm not mistaken.

[/quote]
At a similar case I solved the problem by replacing:

$result = system( < at > cmd_stack);

with:

$result = system(join(' ', < at > cmd_stack));

See e.g.: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721043

Regards,
Miklós
--

------------------------------------------------------------------------------

_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 08:35AM
On Mi, 2016-01-06 at 13:37 +0100, Прокси wrote:
[quote]Hello,

I recently upgraded Wheezy backup server to Jessie and since then I'm having
problem with rsnapshot. I'm getting:

/usr/bin/rsnapshot -V sync: ERROR: /usr/bin/rsync returned 2 while
processing backup < at > host

Running rsync commands from 
rsnapshot -t daily 
manually works, it's just that it doesn't work when called from
rsnapshot.

What could be the problem?
[/quote]
Could you please provide details of the complete error message from rsync
(triggering it via -v). rsync doesn't return just an exit code. And closes
without error description.

~ Bene

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 06, 2016 12:06PM
On Wed, Jan 06, 2016 at 05:31:23PM +0100, PASZTOR Miklos wrote:
[quote]On 16-01-06 17:12, Прокси wrote:
[quote]On 2016-Jan-06 16:00, PASZTOR Miklos wrote:
[quote]Have you customized ssh_args by any chance?
[/quote]
No, that line is commented. I do have something like this:

backup backup < at > ip:/ host rsync_long_args=--rsync-path='/usr/local/bin/rsync_wrapper.sh' --exclude-from=/etc/rsnapshot.d/host --delete-excluded
[/quote][/quote]
Please try without the unnecessary single quotes.
Some versions of rsnapshot will run rsync directly without using a
shell to parse the command.

[quote][quote]Some of those arguments could be in ssh_args if I'm not mistaken.

[/quote]
At a similar case I solved the problem by replacing:

$result = system( < at > cmd_stack);

with:

$result = system(join(' ', < at > cmd_stack));
[/quote]
This might solve some problems, but it introduces new problems, like
you can't have directory names or arguments with spaces in them
(unless you take precautions to quote the spaces or something).

[quote]See e.g.: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721043

Regards,
Miklós
--
[/quote]

--
___________________________________________________________________________
David Keegel <djk < at > cyber.com.au> Cyber IT Solutions Pty. Ltd.
http://www.cyber.com.au/~djk/ Linux & Unix Systems Administration

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
rsync error 2
January 07, 2016 04:13AM
On 2016-Jan-07 07:04, David Keegel wrote:
[quote]On Wed, Jan 06, 2016 at 05:31:23PM +0100, PASZTOR Miklos wrote:
[quote]On 16-01-06 17:12, Прокси wrote:
[quote]On 2016-Jan-06 16:00, PASZTOR Miklos wrote:
[quote]Have you customized ssh_args by any chance?
[/quote]
No, that line is commented. I do have something like this:

backup backup < at > ip:/ host rsync_long_args=--rsync-path='/usr/local/bin/rsync_wrapper.sh' --exclude-from=/etc/rsnapshot.d/host --delete-excluded
[/quote][/quote]
Please try without the unnecessary single quotes.
Some versions of rsnapshot will run rsync directly without using a
shell to parse the command.
[/quote]
Removing single quotes worked. Thanks!

[quote][quote][quote]Some of those arguments could be in ssh_args if I'm not mistaken.

[/quote]
At a similar case I solved the problem by replacing:

$result = system( < at > cmd_stack);

with:

$result = system(join(' ', < at > cmd_stack));
[/quote]
This might solve some problems, but it introduces new problems, like
you can't have directory names or arguments with spaces in them
(unless you take precautions to quote the spaces or something).

[quote]See e.g.: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721043
Regards,
Miklós
[/quote][/quote]

------------------------------------------------------------------------------
_______________________________________________
rsnapshot-discuss mailing list
rsnapshot-discuss < at > lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rsnapshot-discuss
Sorry, only registered users may post in this forum.

Click here to login