Welcome! » Log In » Create A New Profile

Please help me with tape drive issues.....

Posted by Dennis Peacock 
Please help me with tape drive issues.....
March 17, 2014 07:20AM
NBU 7.5.0.4 master
NBU 7.5.0.4 media
Master is Solaris 10
Media is Linux Rel 5.5 64-bit
ACSLS 7.2 on Solaris 10
Tape library is a STK SL8500, 12,000 slots, 64 drives. Many drives are T10KB drives. 4 robots in this library. Library is shared between 3 masters.

We are experiencing MANY drive down issues.
This is from one media server:
00:11:30.586 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:13:45.790 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-07.B35 at path /dev/nst17 on attach host
00:13:45.827 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:13:45.827 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context
00:13:45.827 [16828] <3> logstderrmsg: emmlib_UpdateDriveRuntime failed, status=304
00:20:24.256 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=3, Param2=0, LongParam=0
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-1-1-05.B43 - < 0x10190 >
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-1-1-05.B43 has stopped scanning - < 0x80000090 >
00:20:31.263 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:21:12.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=1, LongParam=0
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: SET SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x90 >
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: Changed Path to /dev/nst16(epsdb01) and set scan host to local for 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=0, LongParam=0
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-2-1-02.B24 has stopped scanning - < 0x80000090 >
00:21:16.372 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-3-1-10.B06 at path /dev/nst7 on attach host
00:21:16.410 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:21:16.410 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context

We also have Encryption in place and we are fighting many issues with RC=84/85/86. Most of what NBU says in the logs is "header block" issue.......How can we have header block issues on over 600 tapes?

Please advise?
Please help me with tape drive issues.....
March 17, 2014 07:28AM
Sorry....the log info I got from netbackup/volmgr/debug/daemon log.
Please help me with tape drive issues.....
March 17, 2014 02:16PM
What, if anything changed or did you add new hardware?
- Are you using SSO?
- What does /tpautoconf -t return?
- What does cat /proc/scsi/scsi show

[quote][quote][quote]Dennis Peacock <nbu-forum < at > backupcentral.com> 3/17/2014 8:21 AM >>>
[/quote][/quote][/quote]NBU 7.5.0.4 master
NBU 7.5.0.4 media
Master is Solaris 10
Media is Linux Rel 5.5 64-bit
ACSLS 7.2 on Solaris 10
Tape library is a STK SL8500, 12,000 slots, 64 drives. Many drives are T10KB drives. 4 robots in this library. Library is shared between 3 masters.

We are experiencing MANY drive down issues.
This is from one media server:
00:11:30.586 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:13:45.790 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-07.B35 at path /dev/nst17 on attach host
00:13:45.827 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:13:45.827 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context
00:13:45.827 [16828] <3> logstderrmsg: emmlib_UpdateDriveRuntime failed, status=304
00:20:24.256 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=3, Param2=0, LongParam=0
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-1-1-05.B43 - < 0x10190 >
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-1-1-05.B43 has stopped scanning - < 0x80000090 >
00:20:31.263 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:21:12.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=1, LongParam=0
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: SET SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x90 >
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: Changed Path to /dev/nst16(epsdb01) and set scan host to local for 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=0, LongParam=0
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-2-1-02.B24 has stopped scanning - < 0x80000090 >
00:21:16.372 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-3-1-10.B06 at path /dev/nst7 on attach host
00:21:16.410 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:21:16.410 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context

We also have Encryption in place and we are fighting many issues with RC=84/85/86. Most of what NBU says in the logs is "header block" issue.......How can we have header block issues on over 600 tapes?

Please advise?

+----------------------------------------------------------------------
|This was sent by dpeaco < at > acxiom.com via Backup Central.
|Forward SPAM to abuse < at > backupcentral.com.
+----------------------------------------------------------------------

_______________________________________________
Veritas-bu maillist - Veritas-bu < at > mailman.eng.auburn.edu
[url=http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu]http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu[/url]
Please help me with tape drive issues.....
March 19, 2014 06:03AM
Possible ideas:
Any OS patches that have overwritten the device configuration files, e.g. on Solaris /kernel/drv/st.conf anything that changed the tape drives from being configured for variable block size to fixed block size.
Anyone bulk erasing scratch tapes for tape formats like LTO that cannot be bulk erased.
William
[b]From:[/b] veritas-bu-bounces < at > mailman.eng.auburn.edu [mailto] [b]On Behalf Of [/b]Peacock Dennis - dpeaco
[b]Sent:[/b] 17 March 2014 21:20
[b]To:[/b] Scott Jacobson; VERITAS-BU < at > MAILMAN.ENG.AUBURN.EDU
[b]Subject:[/b] Re: [Veritas-bu] Please help me with tape drive issues.....

No changes.
No new hardware. Same stuff we&#8217;ve been running for years.
We are working with the encryption team to see if they are seeing any issues on the encryption side of the house. We have experienced RC=85 before on backups when trying to append to already encrypted tapes.

[b]Dennis Peacock[/b]
Data Protection and Recovery Engineer

Acxiom Corporation
[b]EML[/b][b] dennis.peacock < at > acxiom.com ([email]dennis.peacock < at > acxiom.com[/email])[/b]
[b]TEL[/b][b] [/b]1+ 501.342.6232
[b]MBL[/b][b] [/b]1+ 501.343.3366
301 E. Dave Ward Dr, CWY0803, Conway, AR, 72032, U.S.A.
[b][url=http://www.acxiom.com/]www.acxiom.com[/url][/b]
[url=http://www.facebook.com/acxiomcorp][/url] [url=http://www.linkedin.com/groupRegistration?gid=2901735][/url] [url=http://twitter.com/acxiom][/url]

[b]From:[/b] veritas-bu-bounces < at > mailman.eng.auburn.edu ([email]veritas-bu-bounces < at > mailman.eng.auburn.edu[/email]) [mailto]veritas-bu-bounces < at > mailman.eng.auburn.edu[/email])] [b]On Behalf Of [/b]Scott Jacobson
[b]Sent:[/b] Monday, March 17, 2014 4:16 PM
[b]To:[/b] VERITAS-BU < at > MAILMAN.ENG.AUBURN.EDU ([email]VERITAS-BU < at > MAILMAN.ENG.AUBURN.EDU[/email])
[b]Subject:[/b] Re: [Veritas-bu] Please help me with tape drive issues.....

What, if anything changed or did you add new hardware?

- Are you using SSO?

- What does /tpautoconf -t return?

- What does cat /proc/scsi/scsi show

[quote][quote][quote]Dennis Peacock <nbu-forum < at > backupcentral.com ([email]nbu-forum < at > backupcentral.com[/email])> 3/17/2014 8:21 AM >>>
[/quote][/quote][/quote]NBU 7.5.0.4 master
NBU 7.5.0.4 media
Master is Solaris 10
Media is Linux Rel 5.5 64-bit
ACSLS 7.2 on Solaris 10
Tape library is a STK SL8500, 12,000 slots, 64 drives. Many drives are T10KB drives. 4 robots in this library. Library is shared between 3 masters.

We are experiencing MANY drive down issues.
This is from one media server:
00:11:30.586 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:13:45.790 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-07.B35 at path /dev/nst17 on attach host
00:13:45.827 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:13:45.827 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context
00:13:45.827 [16828] <3> logstderrmsg: emmlib_UpdateDriveRuntime failed, status=304
00:20:24.256 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=3, Param2=0, LongParam=0
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-1-1-05.B43 - < 0x10190 >
00:20:24.256 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-1-1-05.B43 has stopped scanning - < 0x80000090 >
00:20:31.263 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-1-1-05.B43 at path /dev/nst18 on attach host
00:21:12.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=1, LongParam=0
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: SET SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x90 >
00:21:12.369 [16828] <4> OprSetLocalScanHostByPath: Changed Path to /dev/nst16(epsdb01) and set scan host to local for 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> LtidProcCmd: Pid=1897, Data.Pid=1897, Type=89, Param1=18, Param2=0, LongParam=0
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: CLEAR SCAN HOST for drive 0158.T1BE.0-2-1-02.B24 - < 0x80000190 >
00:21:13.369 [16828] <4> OprSetLocalScanHostByPath: Drive 0158.T1BE.0-2-1-02.B24 has stopped scanning - < 0x80000090 >
00:21:16.372 [16828] <6> WriteEntry: Updating drive 0158.T1BE.0-3-1-10.B06 at path /dev/nst7 on attach host
00:21:16.410 [16828] <16> update_drive: (0) UpdateDrive failed, emmError = 2006002, nbError = 0
00:21:16.410 [16828] <16> WriteEntry: (-) Translating EMM_ERROR_NotScanHost(2006002) to 304 in the device management context

We also have Encryption in place and we are fighting many issues with RC=84/85/86. Most of what NBU says in the logs is "header block" issue.......How can we have header block issues on over 600 tapes?

Please advise?

+----------------------------------------------------------------------
|This was sent by dpeaco < at > acxiom.com ([email]dpeaco < at > acxiom.com[/email]) via Backup Central.
|Forward SPAM to abuse < at > backupcentral.com ([email]abuse < at > backupcentral.com[/email]).
+----------------------------------------------------------------------

_______________________________________________
Veritas-bu maillist - Veritas-bu < at > mailman.eng.auburn.edu ([email]Veritas-bu < at > mailman.eng.auburn.edu[/email])
[url=http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu]http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu[/url]

***************************************************************************
The information contained in this communication is confidential, is
intended only for the use of the recipient named above, and may be legally
privileged.
If the reader of this message is not the intended recipient, you are
hereby notified that any dissemination, distribution or copying of this
communication is strictly prohibited.
If you have received this communication in error, please resend this
communication to the sender and delete the original message or any copy
of it from your computer system.
Thank You.
****************************************************************************

This e-mail was sent by GlaxoSmithKline Services Unlimited
(registered in England and Wales No. 1047315), which is a
member of the GlaxoSmithKline group of companies. The
registered address of GlaxoSmithKline Services Unlimited
is 980 Great West Road, Brentford, Middlesex TW8 9GS.
Sorry, only registered users may post in this forum.

Click here to login