Welcome! » Log In » Create A New Profile

older version issue.... netbackup 6.5.6

Posted by sshapiro 
older version issue.... netbackup 6.5.6
July 15, 2015 03:35PM
Hello,I have a problem with netbackup 6.5.6 running on hp-ux (pa-risc) 11.11 (running oracle 7.3.4)

I am aware that almost everything I've jsut described is old and unsupported, and please don't suggest upgrading, unfortunately this is not possible.

Background (kind of long-winded, but I want to tell you as much as I can to forestall  unrelated questions):
I have a database that is currently running on an EMC cx3-80 backend. It is being backed up via snapshots which are then mounted on another hp-ux 11.11 system running netbackup 6.5. The database files (snapshot) are then backed up using a standard filesystem-type backup scheduled through the normal netbackup policies, etc. (oh - btw - the netbackup master server is 7.6.1)
This all works reasonably well.

We need to junk the cx3-80 in favor of a NetApp. The NetApp will not do the same snapshotting that the cx does, so generally we have moved most of our databases to RMAN backups, which is working pretty well.

However we can't run rman on the 7.3.4 database, and we can't go past 6.5.6 on hp-ux 11. 

So the plan is to go to hot backup for this one database.

We have all sorts of hot backup scripts that we have run over the years and all work well, except in this case. I've burrowed down to the problem being that the bpbackup command, which is being called directly from the hot backup script, is returning a 
"EXIT STATUS 29: failed trying to exec a command".

We've chased this a bit. I've run "bp' to backup some files and that works fine. I've captured the arguments that bp uses to call bpbackup and tried to use the exact same command and arguments calling bpbackup directly. bp works, bpbackup does not, even though they are running the exact same bpbackup command.

I've tried the bpbackup command on various other systems: aix 7.2, hp-ux 11.31 - all work correctly. It is only on hp-ux 11.11 and 11.0 that I'm seeing the problem.

symantec says error 29 indicates a permission and/or resource problem. Obviously that is not the case if bp calling bpbackup works and calling bpbackup directly does not. There is something else going on.

btw - the command I'm trying is "bpbackup  -S herhxp03 /etc/passwd" - I don't think I can get much more basic that that.

I'm hoping that someone who has been around netbackup for a while might have some thoughts of either things to try or places to look or something!

Help!
Thanks

--
Sid Shapiro                                               sid_shapiro < at > bio-rad.com ([email]sid_shapiro < at > bio-rad.com[/email])

Bio-Rad Corporate IT  - Desk: (510) 741-6846   Mobile: (510) 224-4343
older version issue.... netbackup 6.5.6
July 20, 2015 11:15AM
Only got one emailed reply to this - suggested EBU. Not an option. Our DBAs have no interested in trying to set up yet another unsupported system.

I resolved this by avoidance, in case anyone is interested.

I set up a new netbackup policy to just backup the oracle DB filesystems and archive log filesystems. Then using pre-and poost scripts (bpstart_notify, bpend_notify) I put the database into backup modes, started a new archive log, do the backup, then when complete, take out of backup mode.

pre and post scripts work pretty well!
older version issue.... netbackup 6.5.6
July 28, 2015 01:17AM
Hi
thanks for sharing your experience. Can you please paste output of bp.start and bp.end scripts. It will help us understand better.

From: "sshapiro"nbu-forum < at > backupcentral.com
Sent:Tue, 28 Jul 2015 07:38:37 +0530
To: VERITAS-BU < at > MAILMAN.ENG.AUBURN.EDU
Subject: [Veritas-bu] older version issue.... netbackup 6.5.6
Only got one emailed reply to this - suggested EBU. Not an option. Our DBAs have no interested in trying to set up yet another unsupported system.
[quote]
I resolved this by avoidance, in case anyone is interested.

I set up a new netbackup policy to just backup the oracle DB filesystems and archive log filesystems. Then using pre-and poost scripts (bpstart_notify, bpend_notify) I put the database into backup modes, started a new archive log, do the backup, then when complete, take out of backup mode.

pre and post scripts work pretty well!

+----------------------------------------------------------------------
|This was sent by sid_shapiro < at > bio-rad.com via Backup Central.
|Forward SPAM to abuse < at > backupcentral.com.
+----------------------------------------------------------------------

_______________________________________________
Veritas-bu maillist - Veritas-bu < at > mailman.eng.auburn.edu
http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu

[/quote][url=https://sigads.rediff.com/RealMedia/ads/click_nx.ads/www.rediffmail.com/signatureline.htm < at > Middle?][/url]Get your own [b]FREE[/b] website, [b]FREE[/b] domain & [b]FREE[/b] mobile app with Company email.
[url=http://track.rediff.com/click?url=___http://businessemail.rediff.com?sc_cid=sign-1-10-13___&cmp=host&lnk=sign-1-10-13&nsrv1=host][b]Know More >[/b][/url] -->
older version issue.... netbackup 6.5.6
July 28, 2015 02:15AM
sshapiro currious why you are running a database that is about ten years out of support, especially if your DBAs do not want to use the tools native to that version.
 
Glad you got your problem solved, did not suggest start/end scripts as I understood that you wanted a RMAN like solution which was why I suggested EBU.
 
How do you handle the archive logs generated by database while it is in backup mode ? Thinking in RMAN scripts you usually do the online backup and a then backup of the archive logs
 
Regards
Michael

2015-07-20 20:15 GMT+02:00 sshapiro <nbu-forum < at > backupcentral.com ([email]nbu-forum < at > backupcentral.com[/email])>:
[quote]Only got one emailed reply to this - suggested EBU. Not an option. Our DBAs have no interested in trying to set up yet another unsupported system.

I resolved this by avoidance, in case anyone is interested.

I set up a new netbackup policy to just backup the oracle DB filesystems and archive log filesystems. Then using pre-and poost scripts (bpstart_notify, bpend_notify) I put the database into backup modes, started a new archive log, do the backup, then when complete, take out of backup mode.

pre and post scripts work pretty well!

+----------------------------------------------------------------------
|This was sent by sid_shapiro < at > bio-rad.com ([email]sid_shapiro < at > bio-rad.com[/email]) via Backup Central.
|Forward SPAM to abuse < at > backupcentral.com ([email]abuse < at > backupcentral.com[/email]).
+----------------------------------------------------------------------

_______________________________________________
Veritas-bu maillist  -  Veritas-bu < at > mailman.eng.auburn.edu ([email]Veritas-bu < at > mailman.eng.auburn.edu[/email])
[url=http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu]http://mailman.eng.auburn.edu/mailman/listinfo/veritas-bu[/url]
[/quote]
older version issue.... netbackup 6.5.6
July 28, 2015 08:50AM
I asked "you" not to ask! (business reasons for not upgrading the old database, and the DBAs, although they do their best to support an unsupported database, have no desire to inject yet another unsupported process in the mix.

Michael correctly asked - what about the archive logs that are created during the backup? That's a great question which we found was a real problem when we did our first test restore. So we made some alterations. Now I have a policy that just has for selection, the database data files. I have another that just does the archive logs. Only the data-file policy calls the pre-and post scripts to put the database into and out of backup mode.

It turns out that we can call bpbackup from the master server, so although I can't set up a policy dependencies using the netbackup scheduler, I can call both bpbackups in the correct order in a little shellscript that is called by cron on the master scheduler. Although we have not tried to do a restore yet using this backup technique, I have hopes that it will work correctly. We'll be trying the restore this week.
older version issue.... netbackup 6.5.6
July 28, 2015 11:35AM
Congrats on testing!  As you found, it is important to also get the archive redo logs post-backup.

Cheers, Wayne
Sorry, only registered users may post in this forum.

Click here to login